Suexec Awstats (domain.xxx/awstats)

Hello!

Happy new year everyone! 🙂

Well, I have bulid a new server with Custom build 2.0

Quote:

#PHP settings.
Default version of PHP is always php1_release. Possible values for php1/php2_release: 5.3, 5.4, no. php1/php2_mode: mod_php, php-fpm or suphp)
php1_release=5.3
php2_release=5.4
php1_mode=suphp
php2_mode=mod_php
php_ini=no
#Possible values – production or development
php_ini_type=production
ioncube=yes
zend=yes

#Possible value: 2.4
apache_ver=2.4
mod_ruid2=yes
secure_htaccess=no
harden-symlinks-patch=yes


and moved some account on that new server and since that, I cannot use AWStats at www.domaine.xxx/awstats. It return a 500 Error. But Awstats work fine from DA panel.

When I check the apache errror log I got:

Quote:

[Thu Jan 03 20:23:19.096281 2013] [cgi:error] [pid 3221] [client 174.93.000.000:61289] AH01215: suexec policy violation: see suexec log for more details

[Thu Jan 03 20:23:19.096346 2013] [cgi:error] [pid 3221] [client 174.93.000.000:61289] End of script output before headers: awstats.pl


When I check in the suexec log i got:

Quote:

[2013-01-03 20:23:19]: user mismatch (xxxxxxxx instead of apache)


did I need to change all awstats directory user to apache?

Suexec Awstats (domain.xxx/awstats)

Hello!

Happy new year everyone! 🙂

Well, I have bulid a new server with Custom build 2.0

Quote:

#PHP settings.
Default version of PHP is always php1_release. Possible values for php1/php2_release: 5.3, 5.4, no. php1/php2_mode: mod_php, php-fpm or suphp)
php1_release=5.3
php2_release=5.4
php1_mode=suphp
php2_mode=mod_php
php_ini=no
#Possible values – production or development
php_ini_type=production
ioncube=yes
zend=yes

#Possible value: 2.4
apache_ver=2.4
mod_ruid2=yes
secure_htaccess=no
harden-symlinks-patch=yes


and moved some account on that new server and since that, I cannot use AWStats at www.domaine.xxx/awstats. It return a 500 Error. But Awstats work fine from DA panel.

When I check the apache errror log I got:

Quote:

[Thu Jan 03 20:23:19.096281 2013] [cgi:error] [pid 3221] [client 174.93.000.000:61289] AH01215: suexec policy violation: see suexec log for more details

[Thu Jan 03 20:23:19.096346 2013] [cgi:error] [pid 3221] [client 174.93.000.000:61289] End of script output before headers: awstats.pl


When I check in the suexec log i got:

Quote:

[2013-01-03 20:23:19]: user mismatch (xxxxxxxx instead of apache)


did I need to change all awstats directory user to apache?