Your PHP MySQL library version 5.5.14 differs

I am playing around using an external mysql database server for DirectAdmin.

My DirectAdmin server is running centos 6.3 and my database server is running Debian Squeeze.

When I login to PHPMyAdmin the following message is displayed at the bottom of the web page:

"Your PHP MySQL library version 5.5.14 differs from your MySQL server version 5.1.63. This may cause unpredictable behavior."

I do not think this will look very confidence inspiring to anyone using PHPMyAdmin.

How serious might any issues be if I leave things as they are or what might my options be for resolving this issue?

I am not sure I would want to use a source install of mysql on an external server. If I purchased a second DA licence and used it just for an external Mysql server I suppose this would resolve the issue, but are there any more cost effective options?